Virtual Webcam no Longer Works

Not that it’s a great option, but I’m using the ManyCam Full-Screen mode, then sharing that Full-Screen window until I find another alternative.

Here’s a workaround I spotted.

Update April 17th, 2020: Thanks to Patrick Wardle who helped me figure out that if you unsign the latest version of Zoom on MacOS, it allows these 3rd party libraries to load. I have confirmed Wirecast virtual camera and Blackmagic devices show up after unsigning Zoom.app on the current latest which is 4.6.11 Steps below.

  1. Update Zoom to the latest version
  2. Install Xcode via Terminalxcode-select --install
  3. Once installed make sure Zoom is closed and run this in Terminalcodesign --remove-signature /Applications/zoom.us.app/
  4. Launch Zoom and try virtual cam or Blackmagic capture device

Source: https://www.reddit.com/search/?q=zoom%20disabled%20virtual%20cameras

4 Likes

This worked just as advertised! Thank you!

Thank you for fixing this!

I was able to run the following. Afterwards, everything worked great.

sudo codesign --remove-signature /Applications/zoom.us.app/

Hi @vg1943,

Alternatively you can install older version of Zoom: https://zoom.us/client/4.6.19178.0323/Zoom.pkg

1 Like

Given that hard realtime is about to be hard required by Apple to notorize your apps, is seems like virtual cams have been hammered by Apple. Has Apple provided any guidance? I’d love to start using this with my app again, but most users arent going to install Xcode and strip out the signing.

I have the same issue, how to get notified this is fixed? It was working before, some sure it’s webex, or apple or manycam had some updates that mess this up.

The workaround to install a backdated version (4.6.8 or earlier) will NO LONGER BE AN OPTION on May 30 due to a required update that Zoom is enforcing related to a move to GCM Encryption.

https://zoom.us/docs/en-us/zoom-v5-admin.html?zcid=1231

I used ManyCam on my MacBook Air on both Zoom and gotomeeting non -stop up until early last week. then I was offline, blew up my computer and now have a new macbook pro. for both gotomeeting and zoom, today, I tried to use the virtual background from ManyCam and it didnt’ work. for gotomeeting, I could see the background but not me - when I used the regular Mac camera it should me and the chroma key screen…

is this problem related to the same issue? is there another solution? we are gotomeeting/gotowebinar subscribers. Thank you for any help!

Hello everyone,

Here’s a quick update with known workarounds:

  1. Skype. Try using the web version (best use it in Chrome): http://web.skype.com/
  2. Webex join from browser: https://help.webex.com/en-us/nrbgeodb/Join-a-Webex-Meeting#id_135013
  3. Zoom: virtual webcams are now enabled in the latest Zoom update.https://zoom.us/download

It’s been a month… any solutions on the horizon? If not, what’s the plan from ManyCam perspective? When can we start asking for refunds?

The virtual webcam is working on Microsoft Teams. But it’s not shown up in Skype. Any updates here? @Christopher

I tried Webex on Safari on the Mac, and I’m unable to choose the ManyCam Virtual Camera. So this interim solution does not work for me. Still waiting for a fix!! Possible for ManyCam to chase Cisco (harder) to fix their Webex software?

Hey @Vic,

Safari rarely works with virtual webcams, try Chrome instead. If you get the same problem on Chome, try this guide: https://help.manycam.com/knowledge-base/manycam-virtual-webcam-not-visible-on-a-website/

I purchased ManyCam specifically to use with Skype, so this has been a major setback for me. Can you help us understand more about this? On the surface, it sounds like all you’d have to do is notarize your app. Is that impossible?

Any update on progress to get ManyCam to work with Skype again on Mac?

1 Like

I, too, purchased a lifetime membership of ManyCam specifically for Skype and ability to use in photobooth to record videos. The workaround for Skype works for me (web.skype.com), but I have not heard of any long term solutions, or anything to address photobooth or other mac software. Are there any updates on this?

I planned to buy a lifetime license, but waiting for some bugs to be fixed. @Mikhail: What’s going on here? Any updates to this bug? In Microsoft Teams the virtual webcam is working perfect. It also works with Google Chrome on Mac. What about the other applications? In Skype and Zoom it doesn’t.

Will commercial software be allowed to call virtual cameras

It still does not work in Microsoft Teams

Hey @monkeyword

Please see this thread Issues with MS Teams