Issues with MS Teams

The workaround at the top does not work any longer(from teams version 1.3.00.287788), the update appears to have added some files which need to have their signatures removed. I’ve run the commands below and it sorted the issue.

sudo codesign --remove-signature "/Applications/Microsoft Teams.app"

sudo codesign --remove-signature "/Applications/Microsoft Teams.app/Contents/Frameworks/Microsoft Teams Helper.app"

sudo codesign --remove-signature "/Applications/Microsoft Teams.app/Contents/Frameworks/Microsoft Teams Helper (GPU).app"

sudo codesign --remove-signature "/Applications/Microsoft Teams.app/Contents/Frameworks/Microsoft Teams Helper (Plugin).app"

sudo codesign --remove-signature "/Applications/Microsoft Teams.app/Contents/Frameworks/Microsoft Teams Helper (Renderer).app"

5 Likes

Gary, many thanks. This workaround helped me so much. Great job.

Thanks all for your efforts and advice on this matter. I unfortunately had no joy with the original commands even after dragging. Fandan’s post did however work for me, no amends needed.

1 Like

Thank you, this fixed mine now I’ve installed the latest update to Teams.

Any chance someone could wander along to Microsoft and ask them nicely if they might improve their ability to correctly write a Mac app?

The issue as I understand it after digging around is that Microsoft and Apple not playing nicely together. And it pains me to say that as I am a dedicated iSheep! As I understand it when Teams runs, because of the Apple security in code signing that means Apps will only be able run ‘things’ that are part of the same ‘security signing’ when Teams attempts to access ManyCam, because the security signatures are different, Apple security won’t allow Teams to access ManyCam and therefor the virtual cam becomes unavailable to Teams.
(Apologies for the Layman’s explanation - technical guys - please dont beat me up!)

I can see why Apple has done it from a security point of view(You would not want an App being able to call/access/just anything) and I can see why Microsoft have shrugged their shoulders at it - I guess saying ‘nothing to do with us’! And to be honest I dont have enough of technical understanding to figure out how it might be addressed. I guess until more people kick up a fuss, neither will move on it - but it effectively involves two companies not talking to each other at a deep enough level - at the expense of us lot.

My pleasure Lars, it took me ages to figure it out and thought might be useful to others.

I’ve also noticed that Teams Notifications don’t work like other notifications, and constantly popup underneath the standard notifications I have sitting there. So frustrating, but I’d rather sit here working on my Mac than having to use the work laptop, so I just have to put up, but also frustrated by the number of Teams Updates and then having to. repeat this work each time.

They are currently working on it and scheduled to be released soon.

Thanks a lot!

Just FYI: I use Mac OS Big Sur. Dranging and Dropping the App to Terminal entered a few Backslashes I hat to remote by hand. After that it worked (Don’t know if this is an issue to the OS).

And this also works for other Microsoft Apps such als Skype and Skype for Business.

Thank yon for your collective generosity in helping solve issues. Sadly I’m still stuck. Can’t seem to use ManyCam with anything other than zoom. The MS fixes didn’t work. Got blocked at the input code in the terminal. No invite to add password. Can anyone help - please. Super frustrating

Do you have Xcode installed on your Mac? If not, download from Mac AppStore. I think, the included developing tools are necessary to use the terminal commands mentioned earlier.

Thanks, this fixed the issue.

Hi Paul,

did you manage to resolve? When you say you got blocked? can you share screenshot of error/what blocked you?

Hi all, thank you so much for sharing your fixes and ideas!
I experienced the same problem, tried Fandans fix with the 5 commands, and it worked!

BUT, today I accidentally updated TEAMS (jan 18 2021) after I clicked ‘check for updates’ (unfortunately it then starts updating right away… sigh…)
And now even the 5 commands don’t seem to work (still no extra option for camera input in device settings).

Any ideas of there is still a workaround possible…?
Or do you know if/where I can install an older version of Teams?
(I have a Mac with BigSur,and Timecapsule is not working unfortunately, don’t have an extra backup disk)

Thanks so much in advance!
Rose

UPDATE
I somehow fixed it myself!!
How:
still with the 5 commands, only in this way:
!!! everytime copy paste this command: "sudo codesign --remove-signature " AND then drag the app from Finder to complete the command with the correct location on your Mac computer, and press ENTER.
So it looks like this:

Rose’s-imac:~ Rose$ sudo codesign --remove-signature /Applications/Microsoft\ Teams.app

!!!Then Terminal asks for your password, so type it (it will not show, but Terminal will read it) and press ENTER!!!

Password:

Rose’s-imac:~ Rose$ sudo codesign --remove-signature /Applications/Microsoft\ Teams.app/Contents/Frameworks/Microsoft\ Teams\ Helper.app

Rose’s-imac:~ Rose$ sudo codesign --remove-signature /Applications/Microsoft\ Teams.app/Contents/Frameworks/Microsoft\ Teams\ Helper\ (GPU).app

Rose’s-imac:~ Rose$ sudo codesign --remove-signature /Applications/Microsoft\ Teams.app/Contents/Frameworks/Microsoft\ Teams\ Helper\ (Plugin).app

Rose’s-imac:~ Rose$ sudo codesign --remove-signature /Applications/Microsoft\ Teams.app/Contents/Frameworks/Microsoft\ Teams\ Helper\ (Renderer).app

I hope it is clear how I described this. I am not a tech wiz, just your average Jane :wink:

Hi,

good news that you managed to resolve!

You should not have to drag the App anywhere, the process to follow is as follows:

  1. Download latest version
  2. Log out and Shutdown teams if running
  3. click on the update package from the location you downloaded and run through the steps in the installer
  • (this step will puts the updates into the correct place - so no need to drag app)
  1. open a terminal window
  2. copy and paste each of the instructions into terminal to run each of the commands
  • the first instruction will ask for the password - you will not see it as you type in - but it is happening and if correct will be accepted
  • the remaining steps will not ask for password.
  1. start teams and log in
  2. if you get prompted for the app to have access to the camera, mic or anything else - allow this by going to Security and Privacy in preferences.
  • sometimes I have observed that even after allowing it sometimes does not work, in this case shutdown teams, then come back to security and privacy and remove the access - then simply add the access back again. ( not sure why this behaviour but these steps seem to fix)
  • another behaviour is that after upgrade the screen sharing does not work - again, this can be fixed by coming back to Security and Privacy-remove the access for screen recording, then add it back again. (this seems to fix this issue)

Thanks Fandan!
The way you wrote it down is maybe a better description and more complete.

1 Like

Like the others, I had to drag in the files to get the correct command. The following should be correct (no quotes, & need to backslash (“escape”) the spaces):

sudo codesign --remove-signature /Applications/Microsoft\ Teams.app

sudo codesign --remove-signature /Applications/Microsoft\ Teams.app/Contents/Frameworks/Microsoft\ Teams\ Helper.app

Yep, this does it. With the proper escaping of spaces and parentheses…

sudo codesign --remove-signature /Applications/Microsoft\ Teams.app

sudo codesign --remove-signature /Applications/Microsoft\ Teams.app/Contents/Frameworks/Microsoft\ Teams\ Helper.app

sudo codesign --remove-signature /Applications/Microsoft\ Teams.app/Contents/Frameworks/Microsoft\ Teams\ Helper\ (GPU).app

sudo codesign --remove-signature /Applications/Microsoft\ Teams.app/Contents/Frameworks/Microsoft\ Teams\ Helper\ (Plugin).app

sudo codesign --remove-signature /Applications/Microsoft\ Teams.app/Contents/Frameworks/Microsoft\ Teams\ Helper\ (Renderer).app

1 Like

I paste my commands with the quotes - it means you dont need the escape characters. What I suspect is happening is the quotes are being converted to ‘different’ quotes depending on what editor you use to keep the commands. if you use for example the Notes App and you type/enter quotes in there, the quotes are not the same as as the quotes in a proper text editor - they look almost the same - but the ascii value is different. I notice this when writing html or CSS code - I tried to fix something by copying it to Notes - but it messed up the quotes (and a few others) so when pasted back these characters were not recognised.

Quotes from Notes: “
Quotes from Text Editor: "

Both are quotes, one will work, one will not when pasted into Terminal

I’m using Atom for my text editor on the Mac and pasting from there.

I’m guess that’s why some folks have to drag the App and some not - both ways work in the end.

Thanks for pointing that out though, useful for folks to know.

unfortunately none of this worked for me. I closed Teams, opened Terminal, put these command lines in and was asked for my password as was to be expected, and each of the commands seemed to go through. I then opened Teams, but wasn’t asked for permission to use my microphone or camera, and still my ManyCam virtual camera doesn’t show up when I go to my settings and choose from my camera devices. What am I doing wrong?