Having issues editing MP4 Files

I have recently started using the video recording feature in ManyCam and when I went to edit the videos in Vegas Pro 17, the video comes out distorted. Sometimes the sound will be off as well. In fact the sound will start off correct and then somewhere during the video will no longer be synced. I also tried it in Premier Pro and DaVinci Resolve (All my video editing programs are the latest version). The weird thing is that the videos play back just fine in Windows video player. Am I doing something wrong?? My settings for the video were 30fps and 1080p. Or is it just that ManyCam videos can not be edited? I’m really hoping to be able to use the videos I make in ManyCam because it makes filming so much easier with multiple cameras and such. Thanks in advance for any help on this issue.

Manycam does not have a clean output. There are framedrops and some weird thing is going on with the audio. I guess even if noise suppression is off it puts its audio through a kind of filter.
Windows video player is quite tolerant to such things. But Resolve will report “media offline” for every frame dropped.
There is a fix you might use. A software called “handbrake”. Just let your video recode through it. Takes a little time but the output is much better for Resolve and so it might work for Vegas Pro as well.

1 Like

I use Adobe media encoder to convert my recordings in ManyCam to a Constant Frame Rate video. And then proceed to edit them in adobe after effects, premiere pro or DaVinci Resolve