VirtualCam Disappears in all apps

17 July 2020

Hi everyone,

In brief:
After a single use in Zoom. the ManyCam Virtual Cam instance has disappeared - from Zoom and all other relevant applications.

Here’s a more detailed view:
firstly, the environment…
Hardware/OS

  • MacBook Pro/Mac OS Catalina v10.15.5
  • iPhone 11 ProMax (via NPI)/iOS 13.6
  • iPad Pro 12.9 (via NPI)/iOS 13.6
  • Logitech HD Pro Webcam C920
    Applications
  • ManyCam Studio Lifetime v7.3.1.0
  • NPI Virtual Input v1.0 (1)
  • Zoom: v5.1.2 (28648.0705)
  • Skype v8.62.0.85
  • Microsoft Teams v1.3.00.15561
  • Cisco WebEx v40.7.3.9
  • Aside from the (very) recent addition of ManyCam to this environment, the hardware/software platforms are very stable. All of the hardware/firmware/software components are current, up-to-date, and otherwise non-problematic.

Now the issue…

  • After using the Demo (Free) version, I performed an Uninstall, purchased the Studio Lifetime edition, performed a clean install, activated the Subscription, and restarted the MacBook Pro.
  • Launched ManyCam, set up several presets and combinations of video sources - one with only the Logitech USB webcam, others with both the Logitech webcam and NPI devices (iPhone and iPad Pro’s as previously described), and one with a Lower Third banner.
  • Launched Skype, and the Virtual Cam device appeared in the Devices drop-down. Selected the VirtualCam device, and Quit. Note: the Devices pick list was very slow to load vs. prior to the ManyCam installation.
  • Launched Zoom, and the Virtual Cam device appeared in the Devices drop-down. Selected the VirtualCam device, and Quit. Note: the Devices pick list was very slow to load vs. prior to the ManyCam installation.
  • Navigated back to ManyCam, and the application froze. Restarted the MacBook Pro, relaunched ManyCam, deleted the Profiles and created a single Profile with only the Logitech as a single video source.
  • Launched Skype: no Virtual Cam device appeared.
  • Launched Zoom: no Virtual Cam device appeared.
  • Launched Microsoft Teams: no Virtual Cam device appeared.
    This condition has been reproduced after numerous applications quits and MacBook Pro restarts.

My take on "what just happened"
While admittedly new to ManyCam, this incident has the aroma of file/config/preference/settings corruption, but humility rules the day, (every day), and your collective expertise is greatly appreciated.

My questions, and request for a solution(s)

  • What is the scenario that causes the Virtual Cam device to disappear across all applications?
  • What is the configuration/preference/setting that might have caused this condition?
  • What are the steps to rectify and reliably stabilize the environment?
  • A diagnostic/decision tree that can help avoid symptom tracking becoming a mysterious art form and turning into a black hole of time would be greatly appreciated.

Thanks, regards, & best of health to all,
Marc

Hey @marcjp

Right now I can’t confirm this issue. It might have something to do with ManyCam drivers. Can you try this procedure first?

Uninstall ManyCam as shown here: https://help.manycam.com/knowledge-base/how-to-uninstall-manycam/
Then install this version of ManyCam: https://manycam.com/beta/

Then check to see if ManyCam is available here (on Chrome): https://webrtc.github.io/samples/src/content/devices/input-output/

I just ran a quick check. I’m currently running MacOS Catalina 10.5.6 and ManyCam Studio Lifetime 7.1.2.3. ManyCam works fine with Zoom (5.0.5) and Microsoft Teams (1.3.00.15561). I upgraded to Zoom 5.1.2 and although ManyCam appeared as an option in Zoom I couldn’t select it and the virtual background defaulted to one of their built-in backgrounds. I rolled back to Zoom 5.0.5 and it worked fine again. Is your ManyCam a Beta or have I missed an update?

Most videoconferencing services on Apple devices have experienced virtual camera issues due to recent Catalina OS security/permissions changes, but all seem to have resolved them (except Webex who only currently support virtual cameras on their Web version, not desktop app). The previous Zoom update worked fine, and strangely the release notes for 5.1.2 specifically cites virtual camera support in its list of fixes…

21 July 2020

Hi Tony, and thanks sincerely for the consideration of sharing both your experiences and configurations.

With an otherwise fully working, stable, and optimal hardware/OS/network/software environment, (including a just-updated OS versioning to Catalina 15.10.6), my issue at present seems to be application agnostic:

  • all of the video collaboration platforms (Zoom, Skype, Microsoft Teams), seem to recognize ManyCam’s Virtual Cam upon its initial installation, but once the MacBook Pro is either restarted or shut down and restarted, the VirtualCam device disappears from all of the applications.

  • FYI: I’m currently using NDI with an iPhone ProMax and an iPad Pro, and it works seamlessly and problem-free across all of the named applications. Additionally, I have previously used iGlasses as a virtual device with all of the video sources for those applications - again without issue.

  • The only way I’ve managed to have the VirtualCam device re-appear is to Uninstall, Restart, and re-Install ManyCam, but the scenario then repeats itself in classic Groundhog Day fashion. It leads me to think that the source of the issue is not any single specific target application but rather the link common to all of them.

Thanks again for the value of your time, and benefit of your insights, Tony. If you or anyone else can offer guidance, I remain most appreciative.

Best regards,
Marc

I had the same problem - after sending support ManyCam logs, here’s the reply I received (7 July):

"Our internal team has confirmed the problem and added it to our roadmap. Right now we cannot provide a specific timeframe but we are currently working on the solution and will make sure it’s delivered as soon as possible.

We are sorry for the inconvenience caused and appreciate your patience with this."

Disappointing - the app worked fine for a few days or so, then just quit. I’d be happy to try it again if/when the issue is resolved, but requested a refund - the software is useless to me a this point.

22 July 2020

Hi TCozz,

Thanks for taking the time to reply and add your experience to this thread - greatly appreciated.

So far, ManyCam Support has communicated daily emails inquiring into the basics of the issue, but…
I’m not certain what “adding it to their roadmap” means in the context of our problem(s); software defects tracking and problem resolution is usually an ongoing support function vs. product development’s roadmap & release schedules.

ManyCam is the only unstable solution in my environment, and given that nearly all of our working efforts at present involve mainstream collaboration platforms (Zoom, Skype, Teams, etc.) having a solid, robust and reliable platform is not optional or a “nice to have” - it’s essential.

Thanks again for sharing your insights.

Best regards,
Marc