[SOLVED] ManyCam's "App Window" doesn't appear in Zoom, etc

I am on an iMac 2017 running Mac OS Catalina and ManyCam Premium Lifetime ver. When I add a new layer and then click on the + button to add a video source, I am given many choices. One of these is Desktop -> App Window. When I add an application from the drop-down list that follows, no problem, the App Window shows on the ManyCam screen. But on Zoom, with ManyCam set as the virtual camera, it doesn’t show. It does appear for a few milliseconds and then disappears. Zoom shows other video sources normally, though, e.g. cameras and media files (images and videos). I have the latest version of Zoom, i.e. 5.3.2 (53291.1011).

Do you think that ManyCam lacks the capability to stream running applications when used a virtual camera on conference platforms like Zoom? Or do I need to adjust certain settings in order to make it possible?

Help! This is a very important feature for me to not be working. Thank you for any explanation and direction!

UPDATE: I tried it on a Windows machine, and it worked. That means it’s the Mac OS at fault here. Does anyone know what I should be doing to the Mac file system in order for this to work?

Problem solved. ManyCam should be on just one desktop along with all the applications.