[SOLVED] Manycam Virtual Camera not working

Suddenly my Manycam virtual camera stopped working on my 2019 Mac Big Sur 11.5. It worked perfectly for a year until about 3 nights ago. I am using Premium Lifetime ManyCam.

I uninstall, then reinstall, it comes back. But shutdown Mac, restart - it’s gone.
Doesn’t show up in Zoom or ManyCam as a virtual camera anymore.
What’s changed? Not my OS, although soon I will be updating to 11.5.1

I did the above process of un/reinstall twice, same results.
I then downloaded the Beta to see if it makes a difference.
Nope, same results. I lose it when I shutdown.

I have other Virtual Cams working (mmHmm, for instance, I can see in Zoom as a virtual camera).

Can anyone please help?

EDIT: This morning started my Mac, no Manycam Virtual Camera. But interestingly, the ManyCam Virtual Microphone is present and available!

Hi @Graeme_Pretty,

Please try to run this command in Terminal and see if ManyCam camera appears (may require to restart the client app e.g. Zoom):

sudo launchctl load -w /Library/LaunchAgents/com.visicom.ManyCam.VideoDevice.agent.plist

This command should help until next reboot. If it works, please try to enter:

sudo launchctl enable system/com.visicom.ManyCam.VideoDevice.agent

launchctl enable user/$(id -u)/com.visicom.ManyCam.VideoDevice.agent

Hi @Leo, thanks for this information.
It worked.

I did the first lauchctl command and it restored the virtual cam to Zoom, and mmHmm. So then I did the other 2 commands, and rebooted and the virtual cam is still there.

So, all good until the next issue!

Thanks heaps.