[SOLVED] Getting it to work with XSplit and Twitch

I so want to use ManyCam with my streaming … it has so many neat features. But, no matter what I seem to do, the Framerate on the video is just terrible. Here is an example https://www.twitch.tv/videos/837132872 I started the stream with ManyCam on as my Virtual Cam. You can see it is way off and stutters. Towards the end, you can see where I just turned it off and used the straight cam feed and it works fine.

I do have ManyCam matching Resolution and Framerate with XSplit according to the ManyCam application. It shows the same Resolution and FrameRate I am using in XSplit (1080 and 60 fps). This is version

@captrosha Maybe this happened because the game you play (BTW how do you find Cyberpunk?) consumes all GPU bandwidth. You may try to turn off HW acceleration in ManyCam or switch it to another GPU in windows:

Can you also share real FPS of ManyCam when it drops the framerate:

And also real capture resolution from XSplit:

And lastly, you can save CPU resources if you select lower res since you use small PiP of your camera feed.

1 Like

Thanks for the tips, I will give that a try. ManyCam pops up with a warning that I should have the cam at the same resolution that I am streaming, so that’s why I set it at 1080/60 as well. Enjoying Cyberpunk so far!! This is what I get if I change the resolution in ManyCam.


Ok, I changed it to Disable Hardware Acceleration. I left the resolution as 1080/60 and logged on to Twitch real quick to test … and at the moment, that appears to have worked! I am not seeing the same bad performance as before. I will have to test with a longer stream before I say it definitely resolved it.

Yup, turning off Hardware Acceleration has resolved the issue for me! Thank you so much @ieo