[RESOLVED] Virtual microphone... Can't get rid of delay!

Hi, All.

Do people use the Virtual microphone for their audio source in Zoom or other streaming apps? I’m on a recent (< 8 month old) Windows 10 machine and can’t get my USB mic audio to sync when using the ManyCam Virtual Microphone. If I directly select my USB mic, audio is in sync.

I’ve never used Zoom. I have experienced what you described when using OBS.
I fixed it by trying various fps settings.
Both OBS and ManyCam need to match. That alone did not fix things, I kept trying different matching settings until it worked.
That may help you.

Thanks, Jeff.

So what settings finally worked for you? Were you adjusting anything besides fps and resolution? And how did you confirm you were in-sync? If you’re using OBS you’re only looking at your own computer not syncing over a web stream.

I make videos using obs to capture the screen and also a cam and audio. I’m sure you have seen that sort of thing.
To check its in sync, I watch the recording and look for lip sync.
To answer the other part of your question, yes the only settings I could play with were resolution and fps.
I’ve never done live streaming so cannot comment.
From my I.T. background I can say there would be no difference betwen writing data to a file on a disk or a handle on the network. At that stage it is only data being moved around with the writier having no understanding of what the data is.

Hello @lkling. I had that issue previously feeding my IP cameras into manycam and trying to sync with our sound mixer. However, I was pointed to the audio settings here. image.
Using the dropdown I found the sync offset and used that to add delays to align my video and audio for my stream. If your audio is behind your video you may need to add the delays in the video buffer instead and make sure to remove any delays in the audio.
Hope this helps you!

Thank you, Cleve.

Although I’ve seen the audio AND video offsets I was never able to get them to work right. This time, however, I think offsetting my video by 50ms finally worked. Not perfectly, but close enough!