[RESOLVED] No NDI Input found

I have 5 NDI cameras and they had all been working fine. Something changed either in my PC or network and now Manycam won’t find my cameras when I click on NDI Input I get the error message: “No NDI Input found”. .Sometimes restart clears up the problem, but often not. Sometimes resetting my network (my PC settings network reset) along with a restart clears it up, but not always. Just now its been sitting for a half hour and it appears that it has now re-found them. Our cameras are powered off most of the time via the network switch that powers them (POI).

This is a church’s livestream system so when we come in Sunday morning and sart everything up, the last thing we need os to scramble to fix whatever this issue is

Any help appreciated. Been using many cam for 2.5 years now, and the NDI cams for 6 months.

One more thing to add, I also run newtek’s studio monitor on this same PC and it always finds all 5 cams, and displays and can control them.

Just found another work around, running a CMD prompt commands as follows:

ipconfig /release
ipconfig /renew

As soon s this last one finished all 5 cameras suddenly appeared in manycam.
But why does it loose them im the first place?


well even that only works some times.



I’m having something similar. Running There is no Manycam NDI output. I tried this with Skype and Zoom. Manycam is only outputting black when it comes to NDI

Perhaps this is related to NDI updating NDI tools to Version 5? and Manycam needs an update?

I just did a complete UN-install of manycam and reinstall and reconnect to my licenses, and all worked. Restored my previously saved progecj and all looked good, all my IP cameras were live and well.

Until i restarted my PC and it is back to the same problem,

No NDI Inputs found ?

Freditor, I think your problem is on the output side, mine is input, but they may still have a common thread.

I agree ToMp

It seems NDI-related. I to tried reinstalling, going back to older versions etc. I think it has to do with NDI updating to Ver 5 and now it no longer works with Manycam. But I don’t know I hope Support comes up with a fix. I even looked if I could reinstall NDI 4 but it is no longer available.


I dont believe Ive installed the NDI 5 tools yet. When I look at my NDI monitor tools they are sitting in an “NDI 4 Tools” folder. and these tools and OBS have no proglem finding the IP cams as you noted.

Interesting, Currently it seems like the CMD run as administrator and doing a

ipconfig /release
ipconfig /renew

Is working most of the time now.

And when it works, I can exit manycam and restart manycam an all is still good. but if I sign out of my PC and log back in , manycam is no longer seeing the NDI cams until I do the above release and renew.

Same goes if I restart my PC, manycam no longer sees my NDI cams. but again doing the release/renew and the cams all pop into their scenes.

Today we started upthe Manycam app and theNDI cameras were not found again. MOST perplexing. This time the ipconfig work around did NOT work. So we tried the settings/network/reset andrebot method, and it worked. Pheeeew.

Very disconcerting. I have a second copyon my own personal laptop, and it had no problem accessing the cams, but it is running a slightly older version of Manycam, 7.8.5. The main PC that has the problem si running Also the Main PC is wired ethernet versus the laptop is using Wifi.


When I had NDI problems, I went to the NDI site to see what port they were using and set up my firewall to let that port pass. It was the discovery port for NDI. I found this because it always seemed to work when I temporarily turned of my firewall (which I don’t recommend).


Thanks Steve,

Solution was even simpler. For some reason NDI5 renamed NDI4’s Virtual Input to NDI Webcam Input. Now all works as it should.

Solved: I found windows defender had a bad entry for Manycam Virtual Webcam. I corrected it and marked it as both private and public.

Great, maybe ManyCam support could be better, however I still think they have a pretty awesome app for the price. VMix with decent functionality is $350 USD. Granted they have more functions and MIDI support but there is quite a gap in functionality between their $60 package and their $350 package. If ManyCam had MIDI support for functions, I would have not even been looking outside.

Take care!