[RESOLVED] ManyCam Not Opening- Mac OS X Yosemite 10.10.5 (Latest Version Installed)

ManyCam used to work fine on my Mac, but as of recently it has not been opening at all. I have an older Macbook Pro, 2012 running on OS X Yosemite 10.10.5. Both my Mac is up to date and Manycam is up to date as of today, January 29th 2020. I tried uninstalling, updating, reinstalling. No dice. I tried the supplemental update for Mac OS Yosemite, that wouldn’t work either as I could not complete the update due to a system error.

Opening error for Manycam is as follows:
“ManyCam cannot be opened because of a problem. Check with the developer to make sure ManyCam works with this version of OS X. You may need to reinstall the application. Be sure to install any available updates for the application and OS X.
Click Report to see more detailed information and send a report to Apple.”

Any help is much appreciated, I use ManyCam for work so I really need to solve this soon!


Hi @Cameron_Kruse,

Try out older (6.7) version of manycam: https://download.manycam.com/thank_you_page/mac-6.7
Since ManyCam 7.0 minumum supported macOS version is 10.11, see https://help.manycam.com/knowledge-base/system-requirements/?os=mac

Thanks, but I tried this and the same error messaged appeared once I opened the older version.

Hi @Cameron_Kruse,

Sorry, I don’t have macOS 10.10, so can’t check it. Please try even older version: http://download3.manycams.com/support/DKBV30E/ManyCam-
BTW, new versions of macOS and ManyCam bring a lot of performance improvements, so I recommend you to try to upgrade your macOS again.
You can also try several years old version https://download.manycam.com/thank_you_page/mac-4.6

I was able to find an update for OS and it works fine now. Thanks!