Mobile App rear camera not working

I’m trying to do a Facebook Live, and I can’t get Manycam to access by rear camera. I’ve cleared the presets on the phone, waited 5 seconds, and selected the rear camera as stated in another topic. I even tried a different preset, and it didn’t work. This is the first time I’ve tried to use Manycam on my phone since the last update. It worked before that.

Hey @ChristyF

What is the model and OS version of your phone? What happens when you select the rear camera? Do you see any error messages? Post a screesnhot to illustrate what’s going on.

It’s a Moto z4, Android 9. There is never an error message. If I use the flip camera icon, it looks like the first screenshot. If I clear the preset, & select back camera, it looks like the 2nd picture. Both ways, the preset has the looping circle going (don’t know correct term lol)

@ChristyF, try changing the resolution in ManyCam’s settings from the lowest to the highest. Each time you change the resolution, either pick the camera in a new preset or clear the preset before selecting your camera as a video source.

If this doesn’t help, since we can’t reproduce the problem on our end, I’d like to send you the debug APK of our app in order to isolate the problem.

Let me know if changing the resolution had any effect. I’ll message you directly here on the forum about the debug APK option if you don’t mind.

I was able to get the back camera to work on the 640 x 480 and 1024 x 576 resolutions, but not the others. I would like to be able to use the two higher resolutions. Sending the debug APK would be great.

@ChristyF, the information you’ve provided appears to be sufficient to isolate the issue. Once I have a version with a fix, I’ll send to you here.

1 Like

Hey @ChristyF,

I’ve sent the apk here, please check your IMs.
Please check if you can select the rear camera under all resolutions available in ManyCam. Please specifically check those that prevented you from selecting the camera earlier.

Let me know if you notice anything else.

The same problem for me, i can use only low resolutions but i need higer resolution.
I use the apk on LG G6.

Hey @ChristyF

I’ve sent a new APK, please check your IMs. Let me know if you have any questions.

Hey @Andrea_Suriani,

Thanks for reporting this. We are currently investigating this issue. I can send you a debug APK if you wish to collect the log files to help us isolate the problem. Please let me know.

Can you send it to me too? Same problem on a US997 LG G6

Good day, I have been having trouble with this as well. I was able to use it no problem with the other phones. I am using a Nokia 7 plus, it didn’t have a problem with my front cam, but I will be using the rear cam instead. I hope you will be able to help me with this problem. Thank you.

I am having the same problem with a Moto X4. When I try using the rear camera I get a gray screen and “camera initialization error 4”. This happens with the higher resolutions (1280x720,1920x1080). My camera can go up to 4k. My phone is at Android 10.

Thank you @Mikhail. Unfortunately my account is too new or something–I don’t see PM functionality? Perhaps I need to be upgraded from level 0?

Hey @tony722

I’ve sent an APK to you as well, please check IMs

Hey @namwol55

I’ve sent an APK, please check IMs

Hey there, I’m also having this issue. Would I be able to have the APK as well?

Thanks

Hey there, I’m also having this issue. Would I be able to have the APK as well? Kalle

Hey @Kalle_Lehtiniemi

What version of ManyCam are you using?