Manycam won't install

Hi! Can someone please help me? I installed ManyCam then uninstalled it. My windows 10 was automatic updated and as I was about to download and install latest version of ManyCam, it won’t show any run nor pop-up window for installation. After clicking the “run as administrator” manycam installer just disappeared.

1 Like

Hey @Sincerely_Shai

Thank you for the report, I’m going to look into this. In the meantime here is a separate link for the installer:

I have a similar problem having upgraded from beta to Studio; uninstalled earlier file; reinstalled new file; run the desktop app in OS Catalina but the beta version is still installed. How do I get to the upgraded version; there should just be a button to upgrade???

Hey @techguro

Try the following steps:

  1. Download and install the latest version of ManyCam from our official website:

  2. Follow this guide to activate your ManyCam Subscription:

I am facing the similar problem ,when the file is downloaded in the browser it shows error.
then i reinstall it and the file opens and the installation process is done but when i click the icon to open it then it says the icon is changed or moved so it won’t properly work so do you want to delete it. When i clicked on run as administer the same thing appeared.

Hey @krut_patel

Please check if any firewall or antivirus is interfering. Also, post a screenshot of the error and try a different browser.

same issue here! just stops working. dissapears cant open it. nothing. im using a previous version. help! the beat does the same thing

Hey @Christopher_O_brien

Please try this installer:

Same issue here.
I downloadet Manycam installer and when i run it, it closes in the same moment.
and a few times it was deleted too.
i have all antivirus and things off

Hello @Au5t1nGaming,
If your installer file is named as ManyCam.exe rename it to something like ManyCamSetup.exe and try again.

Hello same problem here… I just buy a licence and i can’t use it!

Hey @Florent_Moal

Have you tried ?

it still does the same thing