ManyCam Not able to share desktop monitor shows me on camera but not my desktop

This is driving me nuts. I am trying to share one of my monitors and each time it shows me on camera and not my monitor. It use to show my a screen before with a white mouse cursor but now it doesn’t show my monitor but another layer of me on camera.

I have made a video here showing me click desktop and selecting the display I want to show (Monitor) and it doesn’t show my monitor. Any help here is greatly appreciated. Quick 1 min video is here showing what I am doing. https://vimeo.com/462327410/c9c11a2a45

Hey @Steve1

First, update ManyCam to the latest version using this link:
https://manycam.com/beta/

Please send the following information to support@manycam.com:

1. DxDiag report:

  • Press Win + R , type-in dxdiag and hit Enter . Then please click on “Save all information” and send the file to Support.

2. Log files from ManyCam:

  1. Start ManyCam and reproduce the issue
  2. Close ManyCam by pressing Ctrl + Q
  3. Press Win + R , type-in %appdata%\ManyCam\Logs and hit Enter
  4. Then select all files from this folder, right-click -> select Send to -> Compressed (zipped) folder . Send the compressed zip folder to Support.

Hi Support. I sent all this information right now. Really want to get this to work. Without being able to share my screen (Monitor) I can’t use this software. Thank you really looking forward to a positive response and this getting fixed.

Is there any update on this, I have exactly the same problem.

Not to be ‘that guy’ but as I just bought this, I’ll refund as I can’t use it to share a desktop.

Hi @Yaffle,
Please try to disable this option:

Thanks @ieo

Sadly that does not work either. As suggested I’ve sent a DXDiag and logs to support.

The only way I can view a desktop is if I use OBS to send it to a virtual camera, then use that virtual camera as an input, which seems a bit silly!

Hey @Yaffle
It seems that you have multiple displays (4) and total resolution exceed maximum texture size in Direct3D10 that is 8192 pixels. That is why capturing displays may not work. I’m aware that some work is in progress for moving to Direct3D11 to overcome this limitation.
BTW do you choose Fullscreen option or one particular display? If Fullscreen, please try to select one of the display only.

Ahh, thanks @ieo
I’ll try unplugging a monitor, but I’m not really going to get chance to try that today. Will revert when I’ve time to do so.

Both cause the issue - fullscreen or display. An individual app window (say Word) is fine, and the pdf, pptx etc ‘plugins’ you have work fine too.

Oh you little genius - that works!

Many thanks.

Hopefully the D3D11 move is smooth for you all.