ManyCam No Longer Loads

Hi there! I have the latest version of MC (7.2.1).

I’ve just noticed that my version of MC no longer works. When I click on the icon nothing happens. It does not show up in Taskbar processes however it does show up in my Device Manager.

I’ve tried clean uninstalling with IOBit as well as installing the BEta version. Nothing seems to work.

I currently have Windows 10 64 Bit. My Windows is updated and I’ve added ManyCam.EXE to my BitDefender exceptions list for the “Safe File” as well as “Firewall Rule” options.

I’d appreciate any feedback with getting MC to work again!

Hey @MrCharou

Try the following:

  1. In Device Manager, click on Imaging devices and choose ManyCam Virtual Webcam -> Uninstall . Please check " Delete the driver software " and press OK .
  2. Uninstall ManyCam and reboot the system, please refer to
  3. Disable antivirus/firewall/defender before proceeding with installation and install ManyCam from our official site

Hi there!

Thank you for the prompt response and feedback!

I tried the above suggestions prior to my post. ManyCam would uninstall itself via the Device Manager, however upon refresh the driver would reappear.

I have managed to solve the problem by doing a fresh install. I felt it was my only option. MC is working perfectly now.