Manycam (Mac) Crashes on opening

Manycam used to work on the Mac (a Mid 2014 Retina MacBook Pro - macOS Catalina 10.15.4) but now it crashes every time I try to launch it. As far as I am aware, nothing has changed on the Mac.

I just get the pop-up box saying ManyCam quit unexpectedly. I tried sending the crash report to Apple and I even emailed ManyCam support (twice) but I have yet to receive even the courtesy of an acknowledgment.

I tried uninstalling and reinstalling. I downloaded the latest version from the ManyCam website (which seems to be 7.1.1 and to be the same version they are showing under Beta!).

I rebooted the Mac. I ran diagnostics on the Mac I uninstalled and re-installed again. I deleted the /Users/username/library/application support/Visicom Media directory and re-installed again.

I have run out of ideas but I need this to work! I paid a LOT of my own hard-earned money for a lifetime studio license and I now have an application that I cannot use. Not at all!

How do I get a refund so that I can look for an application which will work when I launch it? Alternatively, how do I get someone to help me fix the issue?

David

I decided to perform a clean installation of macOS Catalina and now it works again!

1 Like

crash upon start. Uninstalled, rebooted, installed again. Same: crash.

Problem started after I removed ManyCam ApplicationService settings
(as MC didn’t let me include Application-Windows any longer).

Process: ManyCam [3279]
Path: /Applications/ManyCam/ManyCam.app/Contents/MacOS/ManyCam
Identifier: com.visicom.ManyCam.application
Version: 7.1.2.3 (7.1.2.3)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: ManyCam [3279]
User ID: 501

Date/Time: 2020-05-14 13:51:13.625 +0200
OS Version: Mac OS X 10.15.4 (19E287)
Report Version: 12
Anonymous UUID: CECFD7FF-270A-473E-BF5E-4CAED2FF70BF

Time Awake Since Boot: 4900 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

VM Regions Near 0:
–>
__TEXT 000000010bcd5000-000000010d731000 [ 26.4M] r-x/rwx SM=COW /Applications/ManyCam/ManyCam.app/Contents/MacOS/ManyCam

I’ve been having the same issue. Now that I uninstalled and reinstalled, it’s even worse. It used to crash on boot a few times and then would finally open. Now it is crashing on boot every time. I can’t even run their suggested troubleshoot because it won’t even open. By clean installation of Catalina, do you mean, you erased everything else on your Mac?

Hi @Paula_Zapata,

Please report the crash:

  1. Reproduce the crash.
  2. Run Applications -> Utilities -> Console.app
  3. Click on the “User Reports” tab on the left (on macOS Catalina, the tab’s called “Crash reports“)
  4. Find the latest report on the list (ManyCam_2021- … .crash)
  5. Copy the text of the report and save it in a text file.
  6. Send the file to support@manycam.com.

Thank you so much for your suggestion! I did screenshot the crash report prior to posting. I had sent a message to support. I’ve just done what you said and if I copy and paste the entire report text, it’s going to be dozens of pages on the email.

Hey @Paula_Zapata

You can copy-paste the text into a document and send it in the attachment.