ManyCam Forums

Manycam does not start

Hello,
I am on a MBP 2021. I already used Manycam successfully two months ago but today it does not start at all.
I already installed the most recent version, but without effect. It seems that Manycam crashes immediately after launching, but I do not see any error message or something else.
Where can I start to debug this? Are there any log files?
Thanks & regards,
Simon

Hello Simon.
I experienced an issue where I would start ManyCam but no windows would appear, even when clicking on the icon in the taskbar. ManyCam appeared to be running, even in the Task Manager. I was running on two monitors and had ManyCam on on the extended monitor 2. Somehow, ManyCam was having an issue of showing the application window on the primary monitor when there wasn’t a second monitor attached.
I solved the issue by completely uninstalling ManyCam and when reinstalling had to choose the option to not retain any of the settings.
It was aggravating to say the least, but I haven’t the issue since then and keep the main application window on the primary monitor.
I hope this helps.
Cheers.

Thanks, I will try that!
Regards,
Simon

Hi,

I completely reinstalled Manycam on my mac but it did not work.
Any other suggestions?
Thanks & Regards,
Simon

EDIT:
I tried to start the app directly from the console and it tells me that Manycam is already running:


But in activity monitor I cannot see any Manycam process.

@elsim Try to remove settings by removing the .plist file above.

Thanks, but that did not work at all. Is there anyone from Manycam who can help?
Where does Manycam store the “is running” information?
Thanks,
Simon

@elsim

Where does Manycam store the “is running” information?

In system semaphore, so you may try to reboot to reset it.

Hi,

after some time, I still can’t say that the problem is solved.
Yes, rebooting helps temporarily. But there is no guarantee that Manycan will start the next time.

Can somebody from Manycam support in this issue?
Thanks & regards,
Simon

What can I do to get ManyCam to open? Open Windows Device Manager, choose Imaging devices, right-click on ManyCam, and select ‘Enable device’ if you’re having trouble using ManyCam on an app. Similarly, you can check to see whether your system’s built-in camera is activated by doing the same

Thanks, but I am on a Mac :slight_smile:

Hey @elsim

If you are still experiencing this issue, please contact our Support team through this form: ManyCam | Live video software & Virtual Webcam

Thanks @Mikhail , we are in contact!
I will post the solution (we will hopefully find)!

Unfortunately, the problem still exists and I have to say that I feel a bit let down by the support via email.
The enquiries have not been helpful so far. The advise to try the Beta 8 version is useless because I still haven’t received a link to the download despite registering.

The support doesn’t react any more by mail.
That really doesn’t show you in a good light - but I don’t think that really reflects your ambition.


So I’ll try again here, @Mikhail, and ask where ManyCam is reading the information that it seems to have already started - see the beginning of this thread.

Unfortunately, no crash dumps or Manycam logs are written (support had already asked about this).

As already written to support, I would be really happy to be able to use this extremely helpful software on my M1 Mac again - even if only through a workaround until version 8 is officially available.

So once again, I kindly ask for your support.

Many thanks,
Simon

@elsim

I guess the file you’re looking for is located in temp folder, mine is here

/var/folders/3x/npw62srn7ps3bznmln3ps0hw0000gp/T/b09ba522bc847a5acbaa20cc9e5564240928bf83

but yours may be located somewhere else (a temp place chosen by OS), you may try something like this:

find /var/folders -name b09ba522bc847a5acbaa20cc9e5564240928bf83 -print 2>/dev/null


Beta 8 is not yet publicly available, but you may try Lite ManyCam | Live video software & Virtual Webcam

Hi @ieo ,
thanks for your message.
Even with sudo, I don’t find this file at the location you have mentioned.
Could it be that it name is kind of random?
@Mikhail - I think the answer from @ieo is a trace. But any suggestion from your side how I could identify which file this is on my machine?

I would really appreciate to get any feedback from you guys.
Thanks,
Simon

@elsim Location is random, but file name should be the same I guess.

Can it be that another user of macOS is running ManyCam?

Hm, no. I am the only user. And it’s impossible to start Manycam Lite as well. Same message - already started.

I restarted my Mac, ManyCam was able to start (as expected) - let’s see how long it works…
Now I can see the file as long as Manycam is running, but at another location on my machine:

/var/folders/pw/jgxh06cn3gs4_j7qqc31xn0w0000gn/T/

❯ ls -la /var/folders/pw/jgxh06cn3gs4_j7qqc31xn0w0000gn/T/b09ba522bc847a5acbaa20cc9e5564240928bf83
-rw-r-----  1 simon  staff  0  6 Mai 14:55 ./pw/jgxh06cn3gs4_j7qqc31xn0w0000gn/T/b09ba522bc847a5acbaa20cc9e5564240928bf83

Ok, one day later, Manycam is dead again.

❯ ./ManyCam
Settings file path: "/Users/simon/Library/Preferences/com.visicom-media.ManyCam.plist"
ManyCam has already started.
Goodbuy!

But the file in /var/folders is not present => obviously it is not used to determine if Manycam already runs.

I am clueless…

@elsim
Please share output of

ps aux | grep ManyCam