Install macOS Monterey and I can not access my USB camera anymore

Install macOS Monterey and I can not access my USB camera anymore.

I am dead in the water, I installed macOS Monterey and I cannot get my USB camera to work.

It’s working on everything else FaceTime, ZOOM and OBS I have uninstalled and reinstall tried numerous different things on privacy but cannot get it going any ideas?

I did put a support ticket in however it just hang and I got a beachball.

Update for anyone else having the same problem…

To reset macOS permissions so that ManyCam is detected again:

  1. Quit ManyCam if it is running
  2. Open Spotlight by clicking the magnifying glass icon or pressing CMD + SPACE
  3. Type “Terminal” and double click the Terminal application when you see it listed in Spotlight
  4. In the terminal window type “tccutil reset All” and press enter
  5. Re-open ManyCam from the Applications folder
  6. When ManyCam opens, select your camera and microphone in ManyCam so that you are asked for permission for ManyCam to use them again and ManyCam should also appear on the Camera & Microphone tabs of the System Preferences after it has requested permissions.

This actually got it working again good luck for anyone else however it’s now flickering off and on hopefully when I restart my computer it will go back to normal, I spent five hours trying to fix this problem.

Update gone back to not being able to use it nothing will display.

My partner has got the identical set up however her MacBook is a M1 that is the only difference.

after resetting privacy settings, my 2 USB cameras are still “not connected”. Besudes, they show as having the same name. They work fine in Facetime though.

Hi @dehek, @Alex_Danson

Could you please collect logs: https://help.manycam.com/knowledge-base/log-files-macos/
and send them to support@manycam.com

Done it came from danny@dehek.com

This is my setup https://www.dehek.com/general/podcast/7-steps-for-creating-your-own-live-streaming-podcast-studio/

BRANDS, SETUP & GEAR I :heart: LOVE; Apple, WordPress, Podia, Buzzsprout, Benro, WPengine, Crumpler, Final Cut Pro, ManyCam, ZOOM PodTrak P8, Aputure MC 4-Light Travel Kit, Godox LED1000 II, Green Muslin Chromakey Backdrop, BP40 Audio Technica, Proel DST110BK Stands, Takeway R2 Ranger (Pro.Edition) Mounts, DJI Osmo Pocket, Sony A6400, 24mm F/1.8 Lens Carl Zeiss© Sonnar, Connect4k, Bose QuietComfort 35 II, Powerbeats Pro, MacBook Pro, Penguin Ambidextrous Vertical Mouse, iPad Pro, iPhone 12 Pro Max and Garmin tactix Delta Solar. - If you’re looking for support with any of the above just ask.

@dehek Have you tried going to Settings/General/Hardware Acceleration and change it to another setting?
Also, Right click on the LAYER that has the camera, and change the VIDEO FORMAT from MJPG to NV12 … See if the camera comes up. I just helped a friend with this issue and this worked for him. He hasn’t installed macOS Monterey yet…

1 Like

Can you give someone a hug over the Internet that fixed my problem I am so happy I love ManyCam! And I was trying to go back to understanding OBS however I will all green when I was being filmed and I just love the tweaks you can do with ManyCam.

So for others with the same problem I had…

Right click on the layer of the camera, go to properties, switch to NV12 and that fixed my problem.

I did have MJPG selected however it was grey out, when I updated to macOS Monterey it must’ve removed this option?

@dehek I’m so glad it worked. Now I know what to do if I have the same issue after installing Monterey.

Hi.

You all are right, it seems that in macOS monterey popular MJPEG web-camera format is not available at all (don’t know why, maybe bug). This also may break some hi-res resolutions like 4K because 4K is usually provided in MJPEG format.

So if you had this camera format selected in ManyCam and then upgraded your macOS, camera will fail to connect.

As a possible solution, right click on layer with camera, select Properties and change camera format from MJPEG to something else, better Auto.

Another option is using beta: https://manycam.com/beta/

@leo - unfortunately I had to revert to big sur to be able to use manycam, however, I upgraded my laptop to monterey and the problem I have now is that both usb cameras come up with the same name, and I can’t choose the second one, it shows for a split second then it goes to the first one. I believe i saw another thread with this issue

thanks
Alex

1 Like

this is not a good solution. On my iMac Pro, both FaceTime and Google Meet can detect each camera separately, so this is entirely a ManyCam problem. I think it’s time for say good bye to MC and just buy an ATEM Mioni Extreme ISO. I feared that one day, updates will interrupt my workflow and alas it has. I cannot wait for MC to prioritise macOS bug fixes when my livelihood is dependent on seamless camera integration.

Hi @Alex_Danson, @jhumphries79

For two cameras problem please try out beta: https://manycam.com/beta/

1 Like

The beta worked thank you

for some reason my frame rate was at 25, I set it to 30 and the latest beta (7.9) works fine on Monterey