Google can't pick up Manycam (macOS)

Hi everyone

I’ve been using Manycam for online teaching for a while now, and it’s always working on chrome.

I have a feeling there was a pop up message I clicked that changed my settings, so now google can’t find my Manycam. It seems to pick up Manycam microphone but not the actual camera: does anyone know what is going on?

Thank you :slight_smile:
Jack Mitchell.

Hey @Jack_Mitchell,

Welcome to the community. Starting Version 76.0.3809.87, Google Chrome for macOS has had some changes that prevent ManyCam and other apps from appearing on the list of webcam options. The Google team have already confirmed the problem on their end and hopefully they will come up with an update soon. We are also looking for ways to workaround this problem.

1 Like


Some teachers reported that the Opera browser worked with their platforms. Can you try that? Also, what teaching platform do you work with?

That’s not possible for me. I work with iTutorgroup and they can only work with Google chrome unfortunately. I have tried getting an older version of chrome and mine still isn’t detetcting the webcam

You’ll need Chrome 75 for ManyCam to work.

I´m using the latest Manycam and Chrome versions and they just work fine together on so i guess they will work fine on another places.


This occurs only on macs. On Windows, Chrome should be working as usual.

@Jack_Mitchell, some iTutorgroup teachers reported that they managed to get ManyCam working with the Brave browser. As it’s based on Chromium, it should be working fine until they release a new update.

Adding link to the bug in Google Chrome:
Anyone with Google account may “star” the issue and/or add a comment, maybe Google will hurry up if the bug receives many complains.


Thank you I will try that.

Downloading an older version of chrome worked, but I found it updated itself when I turned my laptop on and off.


I was told that Brave browser works great but doesn’t seem to work for me at iTutor platform. I use Mac for teaching online! Thanks.

Hello everyone,

Good news, the issue with Chrome is fixed in the latest Chrome Canary build (version 80.0.3968.0):
Be warned: canary is unstable (“it’s designed for developers and early adopters, and can sometimes break down completely.”) and I don’t recommend it for daily usage, but eventually the fix should appear in the stable version.

1 Like