Global sound giving audio feedback

I want my system sound to go out via the ManyCam Virtual Microphone, but for this to work I need to have Global Sound turned on or nobody can hear my sound. Unfortunately this means they also hear their own sound, leading to feedback. How do I solve this? I’m sure I never used to have to turn on Global Sound but now I do.