Getting echo/feedback when using ManyCam Virtual Microphone

Hi. I’m getting consistent reports from people on Zoom and other webcam apps that when I set my microphone to “ManyCam Virtual Microphone” they’re hearing echo/feedback on my mic feed. It goes away when I mute my mic or when I switch directly to my USB microphone (Samson C01U).

I’ve read through ManyCam’s audio troubleshooting tips and think I have my Win10 audio settings set up correctly:

RECORDING control panel:

  • Microphone (HD Pro Webcam C920) – On/ready
  • Microphone (ManyCam Virtual Microphone) – On/ready and “Default Communications Device”
  • Microphone (Samson C01U) – On/ready and “Default Device”

PLAYBACK control panel:

  • Speakers (Realtek Audio) – On and “Default Device”
  • Headphones (Realtek Audio) – Not plugged in

Any suggestions?

Hey @lkling

Your mic might be too close to the playback device - try headphones and see if this helps.
One more thing to check - disable Audio Monitoring.

Please also go through this troubleshooting: https://help.manycam.com/knowledge-base/audio-troubleshooting/#fix-audio-feedback-echo

2 Likes

I have the same mic on a boom arm above my head.
With no other audio source, guests on Zoom are hearing a slight echo which goes when I use headphones. This wasn’t always the case.

I do think the mic is picking up sound of others on the call from my speakers.

Thank you for the reply, @Mikhail.

  • When I have ManyCam Virtual Microphone selected, wearing headphones solves the problem.
  • When I’m using ManyCam and bypass it’s virtual microphone – by directly selecting my Samson C01U USB mic in Zoom or other webcam apps – I don’t have the feedback issue.

This leads me to believe that even with “audio monitoring” turned off there’s a feedback loop happening with ManyCam’s virtual microphone.

@Stephen_O_Donnell Have you messed around with ManyCam’s “Noise Suppression” setting? I wonder if that might help.