CPU usage is so high nothing else works well

Manycam consumes all my CPU. Period. I’ve rebooted and turned off everything I don’t need. Even reducing it to low priority and to only use 1 of 4 cores doesn’t help much - the cursor still drags slowly and hangs often.

The capabilities of Manycam are awesome, I’m only using the basic functions so far. What can be done to reduce the performance impact? Are there functions I can turn off (until I need them)? Are there registry settings I can change to slow refreshes? What other suggestions do you have to help?

Win 7 Pro Service Pack 1
Processors: 4
Processor speed: 2.5 GHz
Processor type: Intel® Core™ i7-6500U CPU @
Physical memory: 2 MB
Video driver: Intel® HD Graphics 520

1 Like

I am having the same issue. Product works great but the CPU tie up computer Had to work with Apple to get ManyCam to quit working.


Please provide a screenshot of sources that you use and CPU usage in Task Manager. You may also try to use “Hardware Acceleration” -> “Disable” in Settings -> General, maybe GPU is your bottleneck.

Three images with the Windows Resource Manager (CPU window) to show CPU use, and Task Manager to show what things are running.

  1. With Manycam running but idle.

  2. With Manycam running and active.

  3. With Manycam shut down.

  4. With Manycam running but idle.

  5. With Manycam running and active.

  6. With Manycam shut down.

Hi @WesPoteet,
Thank you for the screenshots.

  1. So you have a web-cam in Preset 2, another web-cam in Preset 3 and desktop capturing in Preset 4, right?
  2. Also, do you capture external monitor?
  3. Please help us to locate the problem, please clear presets step by step and let us know how CPU usage changes.
  4. For web-camera please right-click on the live preview and select “Resolution” option where please try to switch Video Format option and check how it affects CPU usage:

(there are extraneous outline entries that are blank. these are artifacts of the editing tool I was using. All the information I intended to be included is present)

(as a new user I can only put 4 images in one reply so my answer is continued in the next reply)

A. Thank you for being a responsive, cooperative, and competent support team. That is far too rare in today’s IT world.
B. Responses to the above.
a. (1) You are correct, preset 1 is a blank screen, preset 2 is an external web-cam (Logitech, pointed down on my work surface), preset 3 is the integrated web-cam, and preset 4 is the desktop of the laptop itself.

b. (2) There are 4 external monitors. Prior to now I have not added any of the external monitors to ManyCam.
The “screen prints” were taken with the Windows snipping tool on monitor 3. OneNote, for composing this response, is running on monitor 2. Images follow their description regardless of the line spacing.


c. (3) I’ve reduced the screen print size a bit but I will be happy to expose and capture more/different data if you need it.
i. ManyCam running but minimized (idle?)

ii. ManyCam active - same presets as before (base case)

iii. Preset 4 deleted (desktop of monitor 1 - Thinkpad). The drop in CPU was immediate when the preset was removed. Acceptable responsiveness of the mouse returned.

(Continued from previous reply and then continued in the next (last) reply for this update)

iv. Preset 3 (Integrated webcam in the ThinkPad. I think there’s a small but noticeable decrease in CPU.

v. Preset 2 (external webcam) “deleted”. The preset entry cleared the input but the preset option stayed. This is with preset 1 selected (blank blue screen. The dip in CPU at the end was when I selected preset 1.

vi. Preset 2 (previously “deleted”) selected - after having preset 1 selected (previous screen print). CPU increased back to preset 2 (“deleted”) levels

viii. Preset 1 “deleted”. Like preset 2, the content of preset 1 went away but the preset entry remained.


(continued from previous reply. This is the 3rd of 3)
d. (4) Changed the resolution for the external web-cam (Logitech). The behavior was the same after I closed the Resolution pop-up.

NOTE: with resolution Custom, reducing the FPS from 30 to 20 didn’t change the CPU usage.

It seems that the desktop capturing causes slowness. I think the reason is that you have more than 1 GPU, e.g. Intel and NVidia and probably ManyCam runs on one GPU (1) but your external monitor is connected to another one (2). So the flow of the data is the following: ManyCam <- GPU1 <- CPU <- GPU2 <- Monitor. Everything is going through your CPU and consuming all GPU bandwidth what can explain cursor issues. Am I right? Try to connect your display (the one you capture) into the same GPU ManyCam runs on (open task manager to see what GPU is used). You may also try to change Accelerated Capturing option in settings.

1 Like

You are correct - tested and confirmed.

Great job. It was a pleasure working with you.