Very small controls on 4k monitor

I have a Windows 10 laptop with an integrated 4K panel that I’m using with an attached non-4K monitor as my primary display. When I drag ManyCam to the 4K panel it’s tiny, with flea speck-sized fonts and controls. This is a problem for me as I typically use the laptop panel for accessories like chat–and ManyCam. Or–I’d like to. :slight_smile:

I tried tweaking the executable compatibility settings in properties, which mostly worked, but that seems to have the side-effect of causing the 4K display when used as a source to be incorrectly scaled–zoomed in, if you will.

I’ve searched the forums for this topic and haven’t found anything, but I’m also sure I can’t possibly be the first user who’s come across this issue.

Hey @stainless,

ManyCam takes screen density (DPI) from the main display only. I guess in your case laptop screen is not 4K, so ManyCam is tiny on 4K screen. To workaround the issue:

  1. Completely close ManyCam (Ctrl+Q)
  2. Open display settings and make 4K screen your main display:
    image
  3. Start ManyCam and it should have the right size.

You can then rearrange your screens or return everything back.

I’m not sure why ManyCam can’t determine the display density from the screen its currently on like many other applications do.

In the meantime, I’ll use the work around as you suggest, though I greatly prefer having the external (non-4K) display as my main display since, with my physical layout, that’s the one directly in front of me; the laptop (with its 4K display) is then secondary, where I keep auxiliary applications like email, slack, etc.

Hi @stainless,

Moving your post to suggestions, we will definitely work on better 4K monitor support.