Issues with MS Teams

Hi there,

I’ve been using Manycam succesfully with MS Teams for months now. Suddenly, the virtual webcam is not shown in the camera menu of MS Teams. Unfortunately there´s no opportunity to run ManyCam.

What to do?

Regards, Lars

1 Like

Hey @Lars_C

This has to do with the latest MS Teams update. It appears they broke virtual webcam support, so no virtual webcam will work with MS Teams unless they fix this, please see this thread:

This solution from the Microsoft forum worked for me:

had the exact same thing happen to me after updating to the latest version of teams. However, I was able to come up with a solution that resolves the issue entirely. It has to do with how Apple is starting to codesign specific apps to block 3rd party CoreMediaIO plugins. If we remove that codesigning, then it will allow those 3rd party plugins to function again.

The fix is pretty simple. First, completely exit out of Teams, then open Terminal and issue the following two commands:

sudo codesign --remove-signature “/Applications/Microsoft”

sudo codesign --remove-signature “/Applications/Microsoft Teams”

Once you’ve issued those two commands, open up Teams. It should ask you for an administrator password to allow the (now) unsigned application to access your keychain. Once entering your password and selecting, “Always Allow”, the issue should be resolved. (At least until the next update to teams is released).


Thx, I’ll try this workaround.

Hi. Thanks for that, I tested it and it fixed my problem.

I had to drag the two .app files into Terminal to get the link to the file to work, but other than that, ManyCam is fixed and I can use it to bug my colleagues.

Thanks again!

Hi tarquincf,

unfortunately, the workaround doesn´t fix my problem. In the last four weeks, i obviously worked with an older version of teams - the problem disappeared.

After the latest update to Catalina 10.15.6 the problem occured again.

  • I´ve tried the two commands, copying doesn’ work, so I dragged the “” into terminal.

The second command - referring to MS Teams - hasn´t worked so far, (“No such file or directory”), obviously there ist no

Could you be so kind to give me a step by step Help, i´ve to work with teams and manycam on monday…

Thx in advance. LC

Hi TeddyBare,

so far it hasn´t worked yet, I can´t find the…

Can you pls tell me where to find?

Thanks, Lars

… the ManyCam Virtual Microphone is still shown in Teams, only the Cam, Feature doesn´t work.

Open Finder, goto Applications, Microsoft Teams

Right Click Microsoft Teams and Show Package Contents

Contents, Framework, and there you will find the Helper App

Drag that into the terminal Window to get the full path.

Hope that helps.Screenshot 2020-08-30 at 17.24.00

Thx! Now it works…

A huge thanks from me too! Got iGlasses app working with Teams. Native Thunderbolt Display cam pink face looking like I had too much to drink - replaced with proper colours adjusted with iGlasses. Thanks again to both @TeddyBare and @tarquincf!

thanks this looked like a great fix. however in my mac also with OS 10.15.6 I get no camera in teams though it can see the audio input.

I tried the code exactly as @TeddyBare above and dragging the app but still got error message: zsh: permission denied.

purpleheron@Purples-iMac ~ % /Applications/Microsoft\\ Teams\

zsh: permission denied: /Applications/Microsoft Teams

Any other ideas please?

Not sure I know the solutionRalph, but just in case.

Permission denied, I assume your login ID has permission to change, not everyone has their main user setup to do so.

Also I assume you have Teams completely shutdown, if the Helper App is running you might not be able to make the required change?

p.s. Does anyone know why I can’t access this forum at all with Chrome? I have to use Safari.

Thank you very much. The two line fixed worked.

Thanks @TeddyBare I’m looking at this issue again.
I tried @tarquincf solution also, but again just got “/Applications/Microsoft: No such file or directory

So think what you said about “I assume your login ID has permission to change, not everyone has their main user setup to do so” must be the issue.

I’m afraid I don’t really know what this means or how to change this, can you step me through that please?

(Presumably also when I enter the code lines in Terminal I should then be pressing return and entering my password when prompted… which when working would apply the desired changes?)

Thank you! Thank you!!! Thank you!!! This worked. I did have to use the first part and then drag the items into each command, but it worked and I now have the cam control back! Thank you so much!


I have tried this solution and the Teams Helper app keeps giving me the same ‘no such file or directory’, even upon dragging the into the terminal. It does ask me for my password then I get the error. Any ideas? I am on the latest version of teams.

great hack, work fine if you type : sudo codesign --remove-signature and drag the folder…

thanks, it works perfectly…

in Mac OS Catalina, you might first need to get the XCode Command line tools from and install them,
otherwise you get an error “the codesign_allocate helper tool cannot be found or used”
And of course MS Teams will complain that it has been modified when you start it afresh…